Thread Number: 75873  /  Tag: Ranges, Stoves, Ovens
How can I fix it
[Down to Last]

automaticwasher.org's exclusive eBay Watch:
scroll >>> for more items
Post# 997224   6/15/2018 at 06:56 by Charles (Charlotte N.C. )        

I recently bought a house that was built In 1978 and it came with its original almond brown Swanson model b9700 range hood. After I moved in i noticed that the liight on it wozas not working and the fan wasn't getting past the first setting. I was wondering if someone could tell me wats wrong with it or something weather or not it is worth fixing.

  Photos...       <              >      Photo 1 of 4         View Full Size



Post# 997244 , Reply# 1   6/15/2018 at 13:41 by RP2813 (The Big Blue Bubble)        

rp2813's profile picture

Assuming it's not the bulb or the fan motor, you may just need to replace switches for both.  Testing the bulb is easy.  Testing the fan motor I'm not so sure about.

 

Replacing the entire hood isn't a big job.  New ones look basically the same as what you have there, although they won't likely be available in brown.





Forum Index:       Other Forums:                      



Comes to the Rescue!

The Discuss-o-Mat has stopped, buzzer is sounding!!!
If you would like to reply to this thread please log-in...

Discuss-O-MAT Log-In



New Members
Click Here To Sign Up.



                     


automaticwasher.org home
Discuss-o-Mat Forums
Vintage Brochures, Service and Owners Manuals
Fun Vintage Washer Ephemera
See It Wash!
Video Downloads
Audio Downloads
Picture of the Day
Patent of the Day
Photos of our Collections
The Old Aberdeen Farm
Vintage Service Manuals
Vintage washer/dryer/dishwasher to sell?
Technical/service questions?
Looking for Parts?
Website related questions?
Digital Millennium Copyright Act Policy
Our Privacy Policy