Thread Number: 76000  /  Tag: Modern Automatic Washers
Magic Chef Portable Washer Woes
[Down to Last]

automaticwasher.org's exclusive eBay Watch:
scroll >>> for more items
Post# 998479   6/26/2018 at 20:02 by Ultramatic (New York City)        

ultramatic's profile picture

 

 

Since I sold the Maytag A107, my sole washer, until the A806 is ready is a Magic Chef 1.6 portable washer, model MCSTCW16W2. Since I started using it, it refused to give me a cold or warm wash, only hot would function. The fill was sometimes a trickle, other times full force. Then it started continue to fill even when the wash action or spin would start, causing a big flood. OK, so I thought this sounds like a water inlet valve issue. So after finally locating a used one, apparently new ones are NLA, I swapped the part. I worked fine for a few washes. Then it started again, water is down to a trickle, and NO cold water wash or warm, only hot. So it wasn't the water valve apparently. Is this is a circuit board issue then? If so I may just chuck the damn thing. Boy am I sorry I sold my Maytag.

 

 





Post# 998495 , Reply# 1   6/26/2018 at 23:16 by Yogitunes (New Jersey)        

yogitunes's profile picture
this model has a strange auto-temp control setup.....no actual sensor, when hooked to permanent faucets, if Warm was selected, it would cycle the hot side on/off every 30 seconds at a time....

of course when hooked to a sink, the cold side was used, and what ever temp you selected at the faucet...

none the less, that is odd behavior from one of these...

wonder if unplugging for a while would reset it....


Post# 998506 , Reply# 2   6/27/2018 at 04:09 by thomasortega (Los Angeles - CA)        

Strange... I have the same washer, it has a miserable torture life since I unboxed it and it is still works like new.

It's the favorite washer i have in my laundry room. I'm looking forward to get the 2.2 cu ft version.

You definitely got a lemon.


Post# 998546 , Reply# 3   6/27/2018 at 11:04 by Ultramatic (New York City)        

ultramatic's profile picture

 

 

I really do like this washer, but this issue really has ticked me off. At least it's not flooding anymore, yet.

 

I tried unplugging to perhaps be able to "reset", but nope, no change.


Post# 998595 , Reply# 4   6/27/2018 at 16:49 by Ultramatic (New York City)        

ultramatic's profile picture

 

 

The anemic fill. It will have a normal flow once or twice during the cycle, but it will be for a short period. Most of the cycle this is what happens. 


  View Full Size



Forum Index:       Other Forums:                      



Comes to the Rescue!

The Discuss-o-Mat has stopped, buzzer is sounding!!!
If you would like to reply to this thread please log-in...

Discuss-O-MAT Log-In



New Members
Click Here To Sign Up.



                     


automaticwasher.org home
Discuss-o-Mat Forums
Vintage Brochures, Service and Owners Manuals
Fun Vintage Washer Ephemera
See It Wash!
Video Downloads
Audio Downloads
Picture of the Day
Patent of the Day
Photos of our Collections
The Old Aberdeen Farm
Vintage Service Manuals
Vintage washer/dryer/dishwasher to sell?
Technical/service questions?
Looking for Parts?
Website related questions?
Digital Millennium Copyright Act Policy
Our Privacy Policy