Thread Number: 79520  /  Tag: Small Appliances
GE Automatic burner
[Down to Last]

automaticwasher.org's exclusive eBay Watch:
scroll >>> for more items
Post# 1034214   6/2/2019 at 14:57 by Vintage1963 (Ohio)        

vintage1963's profile picture
Hello friends...

Would anyone on this forum know anything about this burner or how to check the wiring inside to see if proper contact is being made? One of my friends looked at it but he said he doesn't know what the problem could be. As stated before, the coils never get to the glowing red stage.


  View Full Size



Post# 1034215 , Reply# 1   6/2/2019 at 15:41 by ea56 (Sonoma Co.,CA)        
Ed,

ea56's profile picture
Did you try using the metal attachment that fits into the bottom of the upper bowel tube? This “lifts” the metal disk in the center of the burner to turn on the high heat setting after you’ve depressed the red button on the base. After the water has risen to the top, the turbulence of the remaining water boiling in the lower pot will cause the magnet to disengage and thereby switch to low heat. As I mentioned before, you could test this with a metal object that is attracted to the magnet and if the magnet lifts up and the coils glow red, then its the burner is working as its designed to.

This burner WILL NOT switch to high heat WITHOUT that metal attachment in place in the tube. Without it, it will only achieve low heat, which will probably not allow the coils to glow red.

Try this and let us know if it works.

HTH,
Eddie


Post# 1034218 , Reply# 2   6/2/2019 at 15:50 by Vintage1963 (Ohio)        
Ed,

vintage1963's profile picture
Hi Eddie!

I tried what you suggested and it still didn't work 🙁. I am resigning myself to the fact that the burner just wants a nice, peaceful, gentle passing after years of faithful service.


Post# 1034220 , Reply# 3   6/2/2019 at 16:08 by ea56 (Sonoma Co.,CA)        

ea56's profile picture
Hi Ed,
Sorry that this doesn’t work. Perhaps some other member may have a suggestion for how you may be able to bypass the magnetic switch and at least use it on high. It’s really too bad that this system isn't working as it was intended to.

Eddie


Post# 1034268 , Reply# 4   6/3/2019 at 06:36 by norgeway (mocksville n c )        
I have one with the complete pot also

I never could get it to work, even with the magnet operating the switch


Post# 1034278 , Reply# 5   6/3/2019 at 11:37 by Tomturbomatic (Beltsville, MD)        

Have you checked the terminal pins and the contacts inside the cord for rust and/or corrosion? Have you tried it with another cord? Do the terminal pins seem loose? Have you looked inside the table stove to see if all of the connections are tight and no wires are broken? With stranded wires, you can have some wires broken which will affect performance. Have you checked to see if the magnet in the center of the burner is rising all of the way? That could be balky after 80 years; inhibited in its movement by corrosion, rust or shmutz.

 

There is only one element and it is operating at less than full wattage so we need to check to see what is preventing full current/voltage from making it to the element.  It could be either end of the cord not making good contact with what it is supposed to contact. It could be the switch not moving as it should. It could be a wire on one side of the switch or the other not securely connected. It could be a wiring connection at the magnet. Clearly, you are going to have to go inside the table stove to look for the trouble. Best of luck.




This post was last edited 06/03/2019 at 13:22
Post# 1034358 , Reply# 6   6/4/2019 at 08:59 by Tomturbomatic (Beltsville, MD)        
I think I found your answer!

Page 14 of the January, 1948 issue of Consumer Reports rates automatic coffee makers. Your General Electric 129P18 was among the 6 tested. Here, I think is the kicker from page 16, "Coffee kept at constant temperature by thermostat." I would be willing to bet that the stuck thermostat is the problem, keeping the stove at the "keep warm" setting instead of  allowing the high heat setting to begin the brewing cycle. 





Forum Index:       Other Forums:                      



Comes to the Rescue!

The Discuss-o-Mat has stopped, buzzer is sounding!!!
If you would like to reply to this thread please log-in...

Discuss-O-MAT Log-In



New Members
Click Here To Sign Up.



                     


automaticwasher.org home
Discuss-o-Mat Forums
Vintage Brochures, Service and Owners Manuals
Fun Vintage Washer Ephemera
See It Wash!
Video Downloads
Audio Downloads
Picture of the Day
Patent of the Day
Photos of our Collections
The Old Aberdeen Farm
Vintage Service Manuals
Vintage washer/dryer/dishwasher to sell?
Technical/service questions?
Looking for Parts?
Website related questions?
Digital Millennium Copyright Act Policy
Our Privacy Policy