Thread Number: 82631  /  Tag: Vintage Automatic Washers
Kitchenaid Hobart KDI-20
[Down to Last]

automaticwasher.org's exclusive eBay Watch:
scroll >>> for more items
Post# 1067370   4/14/2020 at 18:10 (1,077 days old) by IPVCE (Miami, FL)        

Hello,

This is my first time posting on the forum. My wife and I recently purchased a house that came with a Kitchenaid Hobart KDI-20 Imperial model. The house and unit is all original 1980's and the dishwasher looks absolutely new both on the inside and out. I figure there was almost no use to it.

The unit however does not power on. I verified power to the unit, and the insides and dont see anything grossly abnormal to it, like burned wires etc. I purchased the service manual from this site and somewhat troubleshooted it based on the manual but still cant get it to work.

I suspect it may be the timer assembly as the knob turns w/o clicks or stops but I' not sure.

Any help on troubleshooting the unit or bypassing the timer is highly appreciate it as I would really want to fix the unit.

Thanks in advance.

A.S.





Post# 1067384 , Reply# 1   4/14/2020 at 19:00 (1,077 days old) by Repairguy (Danbury, Texas)        

repairguy's profile picture
Iím not a dishwasher expert but I had a kitchenaid like yours that the stud that depresses the door safety switch broke off. When you open the door itís at the top right and the small circle hole in the door is where the switch is. Hope this helps.

Post# 1067393 , Reply# 2   4/14/2020 at 19:27 (1,077 days old) by IPVCE (Miami, FL)        

Appreciate the response.

I verified the door interlock switch and that appears to be working good. I feel it may be something else.

The water had been shut-off from the unit and I opened the faucet allowing water to face the double fill valve unit but also no power.

The other thing I did was to remove the Timer Assembly and connected the motor wires directly to 115VAC and the motor is turning as is supposed to. The knob however turns non-stop, there are no clicks or stops, etc as I assume they would occur.


Post# 1067410 , Reply# 3   4/14/2020 at 21:10 (1,077 days old) by combo52 (50 Year Repair Tech Beltsville,Md)        

combo52's profile picture

If the knob and timer shaft turns without turning the timers cam, you need another timer.

 

John L.


Post# 1067417 , Reply# 4   4/14/2020 at 21:45 (1,077 days old) by IPVCE (Miami, FL)        

Thank you. Will give it a try with a new timer and post back one way or the other for future reference on the forum. Regards.

Post# 1067989 , Reply# 5   4/18/2020 at 17:32 (1,073 days old) by IPVCE (Miami, FL)        

Was lucky to find a new timer that fit the unit. Replaced it in the sequence as described on the Manual. Still nothing is happening. Any thoughts? Thanks in advance.

Post# 1067998 , Reply# 6   4/18/2020 at 18:28 (1,073 days old) by eronie (Flushing Michigan)        

Is the stud that that hits the door switch there?
Upper right hand corner.
Frame= stud. Door= switch


Post# 1068033 , Reply# 7   4/18/2020 at 23:26 (1,073 days old) by IPVCE (Miami, FL)        

Door switch is working properly and stud is present.

Did a bit more troubleshooting and the following is happening:

With the dial in Heavy Scrubs and the Heavy Srub button cycle on: The fan unit on the side turns one for a few mins and then shuts off. No signs of water coming into the unit.

Removed the dual intake valve and disassembled it. The screen looks clean but it seems that both valves are mechanically restricted. Both solenoid coils show proper conductivity but when activated independently dont see the shaft of the valve move up or down.

Also, after testing the valve independently w/ an active water connection there is no water flowing out when the solenoids are activated.

Will continue troubleshooting tomorrow and post back. Would really hate having to get rid of the unit. Granted it has been seating for a while.

Thank you....



Post# 1068152 , Reply# 8   4/19/2020 at 13:50 (1,073 days old) by IPVCE (Miami, FL)        

Twin Water intake valve is working properly. I can not find any other issues with the unit except the TBS thermostat is not testing for continuity. All other components test normal.

With or w/o the thermostat bypassed I get the same result: With the timer on the Heavy scrub setting and having either the Pots and Pans and/o r the Heavy Wash button on, the dry air fan starts. Also this is the only time I hear the timer motor on.

Double verified all leads in the timer plugs and also look good.

Other than suspecting the timer I received is bad....I'm a bit lost here.

Any ideas....

Thanks in advance.


Post# 1068169 , Reply# 9   4/19/2020 at 15:30 (1,073 days old) by combo52 (50 Year Repair Tech Beltsville,Md)        
Motly dead KDI-20 DW

combo52's profile picture

The push-button cycle selector switch can fail on these machines, first look closely for loose or burned terminals on the back of it.

 

Then check for continuity through the various switches in it using the cycle chart- wiring diagram 

 

The problem is most likely in the controls or you could have a rare broken wire where the wires flex in the door hinge area.

 

It is always hard to fix things from my desk, I dough it it would take me more than 10 minutes to figure out what is wrong with this DW if I was there, it is simply not that complicated, at least not if you have worked on them for a living the last 40+ years.

 

John L.

 

 


Post# 1068177 , Reply# 10   4/19/2020 at 16:14 (1,073 days old) by IPVCE (Miami, FL)        

Appreciate the information.

This is why it has me so puzzled. I verified the control switch and the are no burned wires or anything like it. I also tested continuity between the blade terminals on the back of the switch with the switches in the ON or OFF positions and it checks out OK.

Also verified on the repair manual about the thermostat and it is a normally open thermostat which means there should be no continuity between the terminals at room temperature. Also bypassing it did nothing.

I'll test the wires for continuity and post back.

Is there a technical document I could purchase showing how to bypass the timer or to test the timer externally?

Thank you.



Forum Index:       Other Forums:                      



Comes to the Rescue!

The Discuss-o-Mat has stopped, buzzer is sounding!!!
If you would like to reply to this thread please log-in...

Discuss-O-MAT Log-In



New Members
Click Here To Sign Up.



                     


automaticwasher.org home
Discuss-o-Mat Forums
Vintage Brochures, Service and Owners Manuals
Fun Vintage Washer Ephemera
See It Wash!
Video Downloads
Audio Downloads
Picture of the Day
Patent of the Day
Photos of our Collections
The Old Aberdeen Farm
Vintage Service Manuals
Vintage washer/dryer/dishwasher to sell?
Technical/service questions?
Looking for Parts?
Website related questions?
Digital Millennium Copyright Act Policy
Our Privacy Policy