Thread Number: 70103  /  Tag: Ranges, Stoves, Ovens
58 Liberator automatic calrod/sensi-temp surface unit won't turn off
[Down to Last]'s exclusive eBay Watch:
scroll >>> for more items
Post# 930227   4/2/2017 at 17:53 (385 days old) by spacepig (Floridas Emerald Coast)        

spacepig's profile picture
Ok, so we finally got the '58 Liberator installed and it appears everything is working, except the lights in the middle set of buttons. However, the left front burner (the automatic calrod/sensi-temp) is still VERY HOT after shutting it off. Is this typical?? Per a volt meter, there is no power coming to the surface unit, but somehow it is staying out. It's been off as long as 30 minutes and still just as hot. Thanks in advance for any help.

Post# 930230 , Reply# 1   4/2/2017 at 18:02 (385 days old) by combo52 (Beltsville,Md)        
58 GE Range problem

combo52's profile picture

I am not sure what is wrong with your LF burner, but if there is NO voltage at it it is not still heating, if you can give more details or a more accurate description of the problem I can troubleshoot it for you.

Post# 930234 , Reply# 2   4/2/2017 at 19:13 (385 days old) by spacepig (Floridas Emerald Coast)        

spacepig's profile picture
I know it doesn't make any sense that it's still heating even when there's supposedly no power registered at the volt meter, but it looks like that's what's happening. We turned on the other burners and they cooled off fairly quickly, but the LF was still hot and the heat felt constant--meaning it didn't feel cooler at any point, even though the lever was in the "off" position.

We unplugged the stove completely about 15 minutes ago, and now the LF burner is cool to the touch. We are going to open up the backsplash and see if we can disconnect at the calrod lever on the top. If not, we'll try and disconnect the surface unit as we can't have a burner that stays on all the time.

Do you have any other ideas what could be causing this? LMK if you need more info or pictures.

Post# 930236 , Reply# 3   4/2/2017 at 19:38 (384 days old) by panthera (Rocky Mountains)        

panthera's profile picture

Will offer you much more specific solutions than I can - he's the real deal.

Here, however, are general causes for such a problem:

1) Something is wired incorrectly/shorted together.

2) There's a short 'to ground' somewhere in that circuit. (Least likely, but easiest to find.)

3) A switch has broken/sensor broken/something jammed across two contacts of either.


It will be one of those three.


I'd start with the easiest of all. With the stove unplugged from the wall, but the calrod still connected use a VOM (digital or analogue, doesn't matter) to see if there is any continuity between any of the calrod terminals and the stove frame/calrod tubes. Resistance must be infinite. If it's not, then there's a short to ground somewhere in the circuit.

Next, check all the wires from the calrod/sensor back to the control. Make sure there are no bare spots or plugs touching something they shouldn't.

Finally, check the switch/sensi-temp control.


The good news - that temperature sensing system was inaccurate with 99.99% of cookware (they only really worked with the test pan used in the factory to calibrate them) and if it's the culprit, turning it off and running the calrod normally is no loss. Rather the opposite - the late '50s and '60s and '70s were full of stories of how one would work great one day and be awful the next.




Post# 930237 , Reply# 4   4/2/2017 at 19:38 (384 days old) by ken (Ulster Hgts, NY)        

ken's profile picture
I've experienced this on my 58 I got last November. The day I went to look at it the wife made reference to "the burner we couldn't turn off". I brought it home and put it in the house under renovation. I tried it out to see what worked and what didn't. The Automatic burner seemed to work correctly. I could hear it cycle on and off with a pot of water on it. I always unplug it when I leave the house. One day I was there so had plugged it in. At one point I noticed the Automatic burner was hot. Not red hot but hot enough I couldn't touch it. I had not turned it on at all.

Post# 930251 , Reply# 5   4/2/2017 at 22:28 (384 days old) by spacepig (Floridas Emerald Coast)        

spacepig's profile picture
So, we tested the terminals on the LF surface unit with a multimeter (stove was unplugged), and it was getting power all the time, even when the switch was in the off position. As the lever was moved to a higher position, the multimeter would beep louder, and then softer as you'd slide it back to off. At one point, the beeping was slightly intermittent, but still very rapid as if the power was turning off and on. We tested one other burner that did indeed show no power when turned off, and vice versa, so something screwy is definitely going on with the automatic. We ended up disconnecting the power to the switch in the backsplash, so the LF is no longer getting power.

So, now we'll have to figure out how/why the automatic unit gets constant power. Do you think the thermostat is the culprit? BTW, all the wiring looks good (not even dusty!) and there is nothing obvious just from looks. I did take several pictures if anyone thinks those will help.

Post# 930252 , Reply# 6   4/2/2017 at 22:30 (384 days old) by spacepig (Floridas Emerald Coast)        

spacepig's profile picture
Thanks for your reply. Glad it's not just me who's had this problem. It seems most everyone has the opposite problem with the burner not heating up very well. For us, unplugging the stove every time is not an option so hopefully we'll be able to figure out the problem.

Post# 930258 , Reply# 7   4/2/2017 at 23:05 (384 days old) by panthera (Rocky Mountains)        
Pictures are always good

panthera's profile picture

An expert can tell you more, but my guess is that the most likely cause is a stuck contact.

There are exceptions, but in most ranges, the power to only one of the two 'hot' lines is cut off when the switch/thermostat is turned off.

If there's a stuck contact or an unexpected ground, then an element can get 120V - which would lead to a 2650 Watt element running at about 662 Watts. This would leave it really hot, obviously, but not glowing bright red, even in a darkened room. Try turning plugging the range in, leaving it for a few minutes than turning the lights off. If it's hot but only barely glowing or not at all, then somewhere -almost certainly in the sensor circuit - either a relay or bimetal contact has become stuck in the 'on' position. 


Post# 930293 , Reply# 8   4/3/2017 at 06:33 (384 days old) by spacepig (Floridas Emerald Coast)        
Thanks for the tip.

spacepig's profile picture
That particular surface unit is completely disconnected now. However, when the calrod lever as in the off position, the burner did not glow at all. However, you could place your hand just above the burner and feel a constant heat. There's another switch which turns on just the inner coil, and flipped another way, turns on the outer coil as well. When we flipped that switch to have both inner and outer coils on, you could definitely feel the heat coming off of both coils, even though the calrod lever was all the way in the off position. When flipping the switch to just the inner coil, you could feel the heat just coming from the middle, all the while the calrod lever being in the off position.

I'm getting ready for work now, so will try and get some pictures loaded this evening when I get home. Thanks for all the help!

Post# 930299 , Reply# 9   4/3/2017 at 07:43 (384 days old) by combo52 (Beltsville,Md)        
58 GE range automatic burner problem

combo52's profile picture

I am not as familiar with these earlier automatic elements as the newer generation system that GE started using in the early 60s-the mid 80s.


That said I would get a hold of the service literature and try the tests they suggest. It could have a stuck contact as Keven suggests, ALL surface elements on ANY 240 electric range ever built turn off both sides of the incoming power lines when the element is turned to the off position, so in any case it should be shutting off completely when it is turned off.


It would be interesting to reconnect the power to this burner and see if it works properly and different cooking tasks, if it does you may just want to install an auxiliary power switch to kill the power for this element when you are not using it.

Post# 930312 , Reply# 10   4/3/2017 at 09:12 (384 days old) by panthera (Rocky Mountains)        

panthera's profile picture

With all due respect to your tremendous knowledge, I've worked on too many ranges through the years not to have noticed that some of them actually don't cut both sides. We have a Monarch in our collection (late 1940s) which doesn't cut both Land L2, just one leg when turned to 'off'.

I was trying to cover all the bases - when an appliance is pushing 60 and still working, there's a very good chance somebody has been inside it and done work at some point. Our 1953 Westinghouse Rainbow had flipped Land Lto the pilot line on some of the switches - and some tech. had fixed the problem and left a note about it in the 1960's. Our 1957 Westinghouse could have been built in 2017 as far as the controls were consistently wired.


I just never make assumptions on something I can't test myself.

Post# 930325 , Reply# 11   4/3/2017 at 10:45 (384 days old) by turquoisedude (Ogden & St-Liboire (where??), QC, Canada)        
This sounds familar....

turquoisedude's profile picture

When I first installed the '56 Wonder Kitchen, the RF "Automatic Calrod" had a similar issue - the unit appeared to be off, the pilot light was off, but the coil was still getting hot.   I figured out pretty quickly that if I set the control dial to what I thought was the off position (with the dial pointer pointing up and at the center of the pilot light lens) the unit was still getting power.  I found that by turning the dial pointer a little further to the left, the power got shut off.    My first thought was that the control was shot, but technically, it was 'new' since the whole kitchen had been sitting uninstalled for 52 years.  It turned out it needed an adjustment.  


I don't remember exactly what we did, but Phil and I took the control out of the panel and made a slight adjustment to the dial.  Darn it, I wish we'd photographed what we did!!

  View Full Size

This post was last edited 04/03/2017 at 11:01
Post# 930329 , Reply# 12   4/3/2017 at 11:14 (384 days old) by combo52 (Beltsville,Md)        

combo52's profile picture
I do happen to know that GE NEVER built an electric range where both sides of the line are not disconnected when the element is completely turned off, I was not making assumptions. UL requires both sides of the line to disconnect when a surface element is turned off.

It would be great if you would post a picture of your Monarch range it be really cool to see.

John L.

Post# 930333 , Reply# 13   4/3/2017 at 11:44 (384 days old) by Spacepig (Floridas Emerald Coast)        
OK I feel stupid.

spacepig's profile picture
Do electric stoves have pilot lights? I thought only gas stoves had these so I'm confused by the reference.

Post# 930339 , Reply# 14   4/3/2017 at 12:22 (384 days old) by norgeway (mocksville n c )        
Not that kind...

Indicator lights would be the correct term, just a c-7 or neon bulb that tells you when the unit is on, If that 58 were mine I would take all that automatic stuff out and install a pushbutton switch to replace it, then you wont have any more problems, I really have never had one that I got any service out of except a big 70s Westinghouse, and it scortched things on simmer..good for frying but not much else...Give me pushbuttons anyday, once you get used to fixed heats you wont go back to infinite.

Post# 930375 , Reply# 15   4/3/2017 at 15:40 (384 days old) by panthera (Rocky Mountains)        

panthera's profile picture
You're the expert. I just have learned to distrust the wiring anything I didn't repair myself. There are pics of the Monarch, I put them up in....2010? I'll see if I can dig them out. Very pretty stove, horrid oven.

Post# 930451 , Reply# 16   4/3/2017 at 20:23 (383 days old) by spacepig (Floridas Emerald Coast)        

spacepig's profile picture
I do have the service manual downloaded from this site, and have been reading it. However, it doesn't have a "troubleshooting area" to help figure out where to start looking for particular problems. If parts were easy to find and cheap, I would probably just start buying some and replacing certain components at a time and hope something eventually worked.

As for installing a kill switch, that's an interesting idea. We would love to be able to use that burner and that may be an easy/quick solution. There is already a switch on the oven to go from inner to outer coil, so I'm wondering if that could be rewired to be a kill switch, so the outside of the stove would maintain it's original integrity.

First, I am going to contact a couple of repairmen in the area and see what happens. Two companies claim to have been in business for over 40 years, so I'm hoping they have someone who has experience on these old gals.

Post# 930453 , Reply# 17   4/3/2017 at 20:34 (383 days old) by spacepig (Floridas Emerald Coast)        

spacepig's profile picture
Thank you for the information. We did something similar. When facing the stove, the lever for the automatic calrod looked like it could go a little farther to the right in the off position (even though it was not lit up). So, we opened up the back and were able to make it move it all the way to right, but it still didn't work. While the light turned off when the the switch was turned off and vice versa, the burner kept heating.

Now, it may be worth revisiting this with clear, untired minds. It was after 9pm when we started trouble shooting, and this was our very first attempted stove repair, so checking it out with a clearer head after research may have a different result

I've attached a couple of pictures. First one shows with the unit turned off, and second one shows it turned on. The only noticeable difference is the lighted switch when the burner was turned on.

  Photos...       <              >      Photo 1 of 2         View Full Size
Post# 930454 , Reply# 18   4/3/2017 at 20:39 (383 days old) by spacepig (Floridas Emerald Coast)        

spacepig's profile picture
Ah, thanks for the clarification. I thought I had been missing something all this time!

I had not considered replacing the calrod switch with just a regular pushbutton. I think I would be ok with that as it wouldn't change the look of the stove, and it looks like the slot is the exact same size so it would fit. Definitely something to consider if we can't get it operable as is.

Post# 930455 , Reply# 19   4/3/2017 at 20:48 (383 days old) by spacepig (Floridas Emerald Coast)        
Here are some pictures

spacepig's profile picture
Sorry for the flurry of posts. Wasn't sure if I should make one long one or respond separately. Here are some pictures, but not sure if they'll help in any way. The first is the surface unit terminals, and the other two are close-ups of the back of the automatic calrod lever/switch. We were able to get the long part of the plastic gear thing all the way to the left, but it still didn't turn the burner off.

Thank you all so much for the help.

  Photos...       <              >      Photo 1 of 3         View Full Size
Post# 930461 , Reply# 20   4/3/2017 at 21:19 (383 days old) by panthera (Rocky Mountains)        
Great pics, thanks!

panthera's profile picture

And it's the best color of them all - turquoise!


So, OK - if it were my stove, and having grown up with these and remembering the uselessness of the temperature sensor, I'd just go with the switches and cut the sensor out of the circuit. I believe it's an easy fix.

However - just in the spirit of tracking down an easy problem,  (stove unplugged, switch in 'off' or whatever passes for 'off') - please disconnect the wires attached to the black case under the white gear and then see whether there is continuity between any two terminals. Obviously, the pilot light terminals will be an easy test - if you turn the switch back on, they should show continuity. They're separate, however, from the rest of the circuit, so the problem we're looking for is going to be at one of the other sets of contact.

The problem is almost certainly a stuck contact within that case or the sensor unit in the middle of the calrod has failed in the ever 'on' position. At this point, it will be one or the other.


Post# 930489 , Reply# 21   4/3/2017 at 22:38 (383 days old) by spacepig (Floridas Emerald Coast)        
You're welcome!

spacepig's profile picture
Thanks for the info and those specifics. It may be the weekend before we can test it out again due to our work schedules. Will definitely keep you posted,

As for turquoise, it actually looks sea foam green in the kitchen, due to the warm lighting, so I will definitely have to get lights with different tones to bring out the blue.

Also, because I've been wrapped up in this stove, I didn't mention that I was able to snag some original GE turquoise steel kitchen cabinets over the weekend! Unfortunately, they are fairly rusted, and some have been repainted white, so I don't think they are salvageable to go back to their original state.

Post# 930492 , Reply# 22   4/3/2017 at 22:58 (383 days old) by olddog (Athens, Ga)        
This is interesting

I had the exact same problem tonight with my '56. I was checking the issue with the oven heating the top of the stove and afterwards (realizing the oven door did not close tightly) went on to cook dinner. The same problem with the same burner position happened. I put a pan of water on the burner (to have some weight on the pop up portion of the burner in the center) for just a moment and removed it. The burner started to cool down after I removed the pan. I figured the sensor stuck. I have used it several times since bringing the stove home last week and this is the first time it happened. WOW, glad to find this thread. I have no doubt I just need to get some time under my belt using this stove to learn its quirks and read/re-read the manual until I am comfortable with all the controls.

Post# 935349 , Reply# 23   4/29/2017 at 20:35 (357 days old) by JoleenC (Tennessee)        

Thank you so much for this information. I recently bought a '56 GE Stratoliner and I found the same issue when we reattached the wires to the calrod burner. We are still in the process of cleaning it (the lever switch was stuck in the On position due to grease buildup - Ew) and searching for replacement parts for the other burners, so we just disconnected the eye for now. I can already tell that this forum will be a great resource.

(And now I am going off to read as many posts as possible before making the mistake of asking any newbie questions.)

Post# 935445 , Reply# 24   4/30/2017 at 07:09 (357 days old) by spacepig (Floridas Emerald Coast)        

spacepig's profile picture
Welcome to the group! Please share pix of your Stratoliner. I do believe that is my absolute favorite of the vintage GE's.

As for my stove issues, I have not solved them yet, in fact I think I may have made them worse. I was going to make a whole separate post about them but haven't yet, as I've been too lazy (and frustrated) to sort out all the pictures to attach to explain what happened. Long story short, the burner is still not working and remains completely disconnected.


Post# 935794 , Reply# 25   5/2/2017 at 06:05 (355 days old) by JoleenC (Tennessee)        

I completely understand being too tired and overwhelmed by things and not wanting to deal for awhile. And, the range will still be there next week.

Here's a picture of our Stratoliner. The right front burner is currently disconnected because the infinite switch was burned out (if it did not run at all, that would be fine, but it would not turn off, so, disconnected). The left front Automatic Calrod is also disconnected for the same reason. Hopefully that one is just because of some crossed wires since I have a feeling the control for that would be even harder to find than a compatible infinite switch.

Post# 935796 , Reply# 26   5/2/2017 at 06:24 (355 days old) by combo52 (Beltsville,Md)        
Element Problems On A GE Range

combo52's profile picture

The right front element does not have an infinite switch on this range, but it does sound like you need a new push-button control switch.


The LF element is a little more challenging to fix, you may just want to get two PB switches and change the LF element over to PB control, if ou do this on this range you also need another 8" element like the RR element.

Post# 935875 , Reply# 27   5/2/2017 at 16:36 (355 days old) by JoleenC (Tennessee)        

Sorry, my vocabulary for this particular range is lacking. I'm used to calling the control mechanism an "infinity switch".

We have a push button switch on order and I have the local repair shop looking for more in their used inventory. I want to try the suggestions above on the left front burner before throwing my hands up and switching it for a push button control.

Since it is not our main oven or range (I have a very odd house with two separate kitchens), it has not been a priority compared to leaking bathtubs and sorting through 25+ years of sewing patterns and fabric stashes.

Post# 935903 , Reply# 28   5/2/2017 at 19:54 (354 days old) by spacepig (Floridas Emerald Coast)        

spacepig's profile picture

Where did you order your pushbutton switch from?

I'll try and get pictures together tonight and put together a post of what we did and what went wrong this time so you can learn from our mistakes.


Post# 937674 , Reply# 29   5/11/2017 at 06:21 (346 days old) by JoleenC (Tennessee)        

I found the switch on eBay. Unfortunately, the seller didn't ship it until after the expected arrival date, which means it isn't going to get here until sometime later, probably while I'm on vacation.

Such is life.

Post# 937688 , Reply# 30   5/11/2017 at 07:22 (346 days old) by spacepig (Floridas Emerald Coast)        

spacepig's profile picture
I obviously still haven't posted the story and pictures to go with the last saga with the stove. I'll try and get to that this weekend.

Forum Index:       Other Forums:                      

Comes to the Rescue!

The Discuss-o-Mat has stopped, buzzer is sounding!!!
If you would like to reply to this thread please log-in...

Discuss-O-MAT Log-In

New Members
Click Here To Sign Up.

Discuss-o-Mat Forums
Vintage Brochures, Service and Owners Manuals
Fun Vintage Washer Ephemera
See It Wash!
Video Downloads
Audio Downloads
Picture of the Day
Patent of the Day
Photos of our Collections
The Old Aberdeen Farm
Vintage Service Manuals
Vintage washer/dryer/dishwasher to sell?
Technical/service questions?
Looking for Parts?
Website related questions?
Digital Millennium Copyright Act Policy
Our Privacy Policy