Thread Number: 71510  /  Tag: Vintage Automatic Washers
Maytag LAT4915 won't agitate or turn on
[Down to Last]

automaticwasher.org's exclusive eBay Watch:
scroll >>> for more items
Post# 946225   7/1/2017 at 13:55 by Tomdawg (Des moines)        

I picked up a Maytag LAT4915 today and plugged it it. Started right up but wouldn't spin. I helped it spin by turning the basket and it was able to spin- so the washing and agitating works.however, the washer all the sudden quit working. It will fill but the motor won't turn on. I waited an hour and it still won't turn on. Does this mean I need a new motor or is it the switch? I wouldn't think it's the timer since it fills.

  View Full Size



Post# 946235 , Reply# 1   7/1/2017 at 16:02 by Yogitunes (New Jersey)        

yogitunes's profile picture
if I am correct, that one should have a fuse as well.....but if that was blown, nothing would work....

if I recall as well.....this machine will allow filling with the lid open, but that's all, agitation/spin only with the lid down.......meaning, there are two switches, basically front and back on the plastic panel behind the control panel.....one allows the machine to fill with the lid open, and the other controls everything else.....

I would start there at least....


Post# 946356 , Reply# 2   7/2/2017 at 13:36 by Tomdawg (Des moines)        
Fixed, but more issues

So I put a good size load in and it won't spin unless I help it turn. Then it will take off just fine, is this a belt issue? Do I neee to replace the belts or tranny need some tuning up?

Post# 946358 , Reply# 3   7/2/2017 at 13:47 by mayken4now (Panama City, Florida)        

mayken4now's profile picture
Try the belts or the motor glides may need replacing.

Post# 947179 , Reply# 4   7/8/2017 at 14:35 by Tomdawg (Des moines)        

Ok, so after assessing this past week, I find that the bearings and seal are bad. Not bad for a 22 year old washer. The pump makes some noise and the springs and the motor glides seem wore out. I have no idea if the (radial?) bearing below (where the brake assembly is) is bad too.
I can do this all myself, is it worth trying to fix all this?





Forum Index:       Other Forums:                      



Comes to the Rescue!

The Discuss-o-Mat has stopped, buzzer is sounding!!!
If you would like to reply to this thread please log-in...

Discuss-O-MAT Log-In



New Members
Click Here To Sign Up.



                     


automaticwasher.org home
Discuss-o-Mat Forums
Vintage Brochures, Service and Owners Manuals
Fun Vintage Washer Ephemera
See It Wash!
Video Downloads
Audio Downloads
Picture of the Day
Patent of the Day
Photos of our Collections
The Old Aberdeen Farm
Vintage Service Manuals
Vintage washer/dryer/dishwasher to sell?
Technical/service questions?
Looking for Parts?
Website related questions?
Digital Millennium Copyright Act Policy
Our Privacy Policy