Thread Number: 73672  /  Tag: Ranges, Stoves, Ovens
My New 1955 GE Liberator, and some questions
[Down to Last]'s exclusive eBay Watch:
scroll >>> for more items
Post# 972896   12/10/2017 at 21:14 (286 days old) by jgushman13 (Garden City, MI)        

Hello everyone, I stumbled upon this site, and thought it looked pretty great! I am excited to be among other vintage appliance owners. I just purchased a 1955 GE Liberator stove, sight unseen from three hours away. I just spent Saturday cleaning it and taking apart the back panel. And today I cooked a turkey dinner with all the fixins, and I am happy to say it worked phenomenally!

The stove has the automatic burner...which appears to work? I had a pot of potatoes boiling on it on "hi" and it never boiled over. However I have noticed some people reference a temperature on theirs, but mine reads HI, 2, 3, 4 etc. What is a good way to test if this burner works right?

Secondly, there is a minute timer next to the calrod knob. It buzzes in the right position, but it does not move from the time I set it to. Any tips on fixing this?

Third, the clock does not work. Any ideas here?

Fourth, the burner buttons seem to have different color buttons from one set to another. Example, "LO" on one of them is very green, the other two are basically clear. "HI" on all appears definitely red, however one is much darker and more clearly red. What actually colored these? I know the bulb is just a night light bulb as I replaced two.

Lastly, when putting it back together I snapped the glass disc for the front of the clock. It would seem to be that a local hardware store could cut a piece of glass to fit in here...does anyone know for sure?

Eye candy below...some pics are before cleaning, some are after. I chose to paint in some lettering with white enamel paint. Still needs some cleaning around the edges.

  Photos...       <              >      Photo 1 of 2         View Full Size

Post# 972927 , Reply# 1   12/11/2017 at 00:58 (286 days old) by rp2813 (The Big Blue Bubble)        

rp2813's profile picture

Nice stove! 


I can't offer anything about the button colors or how they worked, but there are probably pictures either in the archived posts here, or elsewhere on the web, or a member may have some literature or the knowledge about them to advise you.  I would hazard a guess that they go from green for "LO" then into yellow and orange, then red for the "HI" button.


Is the minute timer mechanical or does it have an electric motor?  I may be a combination, with mechanical timer mechanism that triggers an electric buzzer of some kind.  If it's mechanical, it probably just needs cleaning and or lubing with clock oil.


I can say with a good degree of certainty that your stove's clock was made by Telechron, a clock company that GE owned when your stove was manufactured.  The likely reason it's not running is because the rotor is gummed up and/or needs oil.  Telechron was a little skimpy with their application of oil.   These rotors were used on all types of GE and Telechron clocks (and a number of other makes) from roughly 1940 until around 1970, but replacements are no longer made.   They can be expensive on ebay, but there's an easy way to revive one.  Unplug the stove's power cord before performing any work.


I'm providing pictures of a type H3 (3.6 RPM) rotor along with pictures of one installed in its coil assembly.  Some have steel housings, others have copper ones.   They're interchangeable as long as the 3.6 RPM specs are the same (stamped on the side of the rotor housing). 


When you access the clock from the rear, you'll see what resembles the assembly pictured below.  If you can extract the rotor without removing the entire clock, fine.  Loosen the screws and swing out the two flat L-shaped sections of the field coil that hold the rotor in place.   If there are spacers surrounding the screws, be ready to catch them.  The coil sections may be a little stiff or sticky, but they'll rotate out of the way and allow you to extract the rotor, which lifts right out.  Be very careful not to disturb the paper wrapped field coil where the 110V wires connect.  These were fragile when new, and are even more so now.   I assume your clock mechanism may include a timer of some kind, so there may be little flaps and doo-dads not shown in the picture below.  Try not to disturb those either.


With the rotor out, find yourself a lamp with a 60 to 100 watt incandescent bulb that is situated vertically, and a can of 3-in-1 Oil with the blue and white label.  Carefully balance the small end of the rotor on top of the bulb, with pinion gear side aimed up.  Turn on the lamp and let the rotor cook for about half an hour.  Turn off the lamp and place a drop or two of oil on the side of the pinion gear so it fills the small well at the bottom of the gear.  As the bulb cools, it should suck the oil in.  Repeat this as the well empties until you've added no more than 15 drops.  Too much oil will bog down the rotor and cause the clock to run slow.  If the rotor stops accepting the oil before you've hit 15 drops, you may need to re-heat and pick up where you left off,  adding only the remaining number of drops to reach 15.  Soak up any oil that might be on the gear or remain in the well.


The rotor will be hot to the touch.  Either let it cool, or insulate your fingers with a rag or paper towel, and place it back into the clock.   Make sure it's properly positioned so the pinion gear meshes with its corresponding gear in the clock movement.   Move the field coil sections back into place to secure the rotor, and tighten the screws -- not too tight, not too loose.   Reconnect the power cord and check the second hand for sweep action.  If there's no movement, the rotor may be shot, but that would be kind of rare.  You could try cooking it again, but I wouldn't add any more oil.  If that doesn't help, you'll need to do surgery, but let's not cross that bridge until we come to it.




Image result for vintage telechron rotor


Image result for vintage telechron rotor



Post# 973528 , Reply# 2   12/13/2017 at 19:53 (283 days old) by jgushman13 (Garden City, MI)        

Thank you so much for the detailed response. I will definitely try this.

Forum Index:       Other Forums:                      

Comes to the Rescue!

The Discuss-o-Mat has stopped, buzzer is sounding!!!
If you would like to reply to this thread please log-in...

Discuss-O-MAT Log-In

New Members
Click Here To Sign Up.

Discuss-o-Mat Forums
Vintage Brochures, Service and Owners Manuals
Fun Vintage Washer Ephemera
See It Wash!
Video Downloads
Audio Downloads
Picture of the Day
Patent of the Day
Photos of our Collections
The Old Aberdeen Farm
Vintage Service Manuals
Vintage washer/dryer/dishwasher to sell?
Technical/service questions?
Looking for Parts?
Website related questions?
Digital Millennium Copyright Act Policy
Our Privacy Policy