Thread Number: 79427  /  Tag: Modern Dryers
Speed Queen Electric Dryer Trips Breaker
[Down to Last]

Cool Washer Stuff on Amazon:
scroll >>> for more items
Post# 1033459   5/23/2019 at 11:25 by stricklybojack (San Diego, CA)        

stricklybojack's profile picture
.
It trips instantly in heat mode. In no heat mode it runs fine.
Arcing on neutral...
Any ideas? Fairly new dryer, 5-6 years old probably.



  View Full Size
Post# 1033469 , Reply# 1   5/23/2019 at 14:29 by Stricklybojack (San Diego, CA)        

stricklybojack's profile picture
.
Answered,
“Bad connection on the thermal fuse. That caused heat which burned up the fuse externally. The temp limit switch may be just fine, but I’ll replace that also.”


  Photos...       <              >      Photo 1 of 2         View Full Size
Post# 1033471 , Reply# 2   5/23/2019 at 14:56 by Maytag85 (Sean A806)        

maytag85's profile picture
Electric dryers can do funky things at times. One problem I ran into or rather had with my DE306 is the wire that went from the heating element to the high limit thermostat burnt out on me, and it did heat, but was making a burning smell. I happened to have the correct gage and color of wire, and I had it up in running with in a couple of days.

I actually posted in a thread awhile back (didn’t make a thread about it), but here’s what the wire looked like


  View Full Size
Post# 1033472 , Reply# 3   5/23/2019 at 14:58 by turbokinetic (Northport, Alabama USA)        
Yep....

... looks like you found the problem!

A little poor contact, high resistance, additional heat, and finally the wire burns off the contact, falls away, and shorts to ground.

I'm sure the new thermal switch (and new wiring terminations!) will take care of the problem.


Post# 1033474 , Reply# 4   5/23/2019 at 15:37 by chetlaham (United States)        

chetlaham's profile picture
What Turbokinetic said. Agree 100%.

Post# 1033478 , Reply# 5   5/23/2019 at 16:55 by Lorainfurniture (Cleveland )        

You should change those incorrect terminal block screws also. The far right is correct.

Post# 1033503 , Reply# 6   5/23/2019 at 19:58 by Repairguy (Danbury, Texas)        

Probably going to have to replace the terminal block cause I’m sure someone forced those incorrect screws in. And might as well order new correct terminal block screws as well.

Post# 1033507 , Reply# 7   5/23/2019 at 20:21 by Combo52 (Beltsville,Md)        
Burned heater terminal connections

combo52's profile picture
Speed Queen and several other electric dryer manufacturers have trouble with terminals burning in the heater circuit. Only whirlpool uses actual silver plated terminals and almost never has this problem they’ve done it right for a long time.

You may also want to replace the heating element on this dryer if the mail terminals are even slightly discolored from overheating.

On the terminal block as long as the connections are good and tight it really doesn’t matter what type of screws are used.

John





Forum Index:       Other Forums:                      



Comes to the Rescue!

The Discuss-o-Mat has stopped, buzzer is sounding!!!
If you would like to reply to this thread please log-in...

Discuss-O-MAT Log-In



New Members
Click Here To Sign Up.



                     


automaticwasher.org home
Discuss-o-Mat Forums
Vintage Brochures, Service and Owners Manuals
Fun Vintage Washer Ephemera
See It Wash!
Video Downloads
Audio Downloads
Picture of the Day
Patent of the Day
Photos of our Collections
The Old Aberdeen Farm
Vintage Service Manuals
Vintage washer/dryer/dishwasher to sell?
Technical/service questions?
Looking for Parts?
Website related questions?
Digital Millennium Copyright Act Policy
Our Privacy Policy