Thread Number: 85327  /  Tag: Vintage Dishwashers
Inherited Kitchenaid dishwasher help
[Down to Last]

automaticwasher.org's exclusive eBay Watch:
scroll >>> for more items --- [As an eBay Partner, eBay may compensate automaticwasher.org if you make a purchase using any link to eBay on this page]
Post# 1098679   11/29/2020 at 14:31 (1,236 days old) by Ellibee (Los angeles )        

Hi,

I inherited a Kitchenaid from my grandmother, which worked great (if I only used the soak & scrub function) until yesterday. Now it won't start, either there are no lights or only the "cycle complete" light no matter what I push. I've turned the power off for a while and back on, no luck. Any ideas?

Thank you!

Model # KUDA230YWH0


  Photos...       <              >      Photo 1 of 3         View Full Size



Post# 1098701 , Reply# 1   11/29/2020 at 17:29 (1,236 days old) by steved (Guilderland, New York)        
Activator pin

Is the activator pin (that activates to door switch) on the upper right hand side of the tub broken?


  View Full Size
Post# 1098751 , Reply# 2   11/29/2020 at 21:55 (1,236 days old) by Ellibee (Los angeles )        
Activator pin

Hi thanks for replying! I think it is okay, it does respond when I close the door ( the cycle complete light turns on), I'll attach a picture.

The buttons just don't seem to respond properly.. almost like they are stuck? And then when I open the door and close it again, the cycle complete light doesn't turn off. It does turn off when I press a different cycle, but still doesn't start.


  View Full Size
Post# 1098820 , Reply# 3   11/30/2020 at 14:08 (1,235 days old) by Awooff (Peoria, Illinois)        
Internal timer not at end of previous cycle??

awooff's profile picture
If you push the cancel button w door latched, the timer should advance to the end of the cycle - and then should be ready with clean light off maybe?..

Additionally, in my opinion, a machine of this age should have a new water valve installed - a 50.00 part. -short fills will affect wash performance.


Post# 1098866 , Reply# 4   11/30/2020 at 19:41 (1,235 days old) by Ellibee (Los angeles )        
Timer?

Maybe the timer is the issue then... do you know a way to check it? Can I take it apart somehow?

And that sounds like a good idea, I don't know if it's ever been changed!


Post# 1098890 , Reply# 5   11/30/2020 at 23:07 (1,235 days old) by RP2813 (Sannazay)        

rp2813's profile picture

These rapid advance timers are complex and unless it's an easy fix like a loose/broken/disconnected wire or a corroded connector, etc., they don't lend themselves to repairs.  Replacements are no longer available but they have been known to show up on ebay. 


Post# 1098892 , Reply# 6   11/30/2020 at 23:22 (1,235 days old) by bigalsf (Salt Lake City)        
Program switch

I believe your problem is with a part called the program switch reset lever. When you open the door the program switch button is supposed to move back out. When you close the door you have to push the button again to start the machine. In your picture with the door latch open I see the button is still pushed in. That is not correct, and is what is causing the problem. When you open the door after a cycle is complete a lever attached to the handle moves against the program switch and forces the button out (it resets). This action closes a switch to the rapid advance motor on the timer which resets the timer for a new cycle. Because the lever is not working the program button does not reset and the switch is not closed; the timer is not reset and thinks it's still at the end, thus the "Clean" light glows.

If it's not the lever, than the program switch is broken and must be replaced (it cannot be repaired). Parts for these are available, but you'll have to do some searching. Try Repair Clinic, Ebay, etc. Neither repair procedure is easy, but if your mechanically inclined you should be able to pull it off. A service manual for this model can be downloaded from the Ephemera section.

Good luck and keep us posted.


Post# 1098966 , Reply# 7   12/1/2020 at 17:21 (1,234 days old) by stevet (West Melbourne, FL)        
Good Call, Alan

I have seen the reset lever out of adjustment from time to time. Sometimes people would press the buttons before latching the machine and it makes the lever get out of adjustment.

It is easy to check by removing the screws that hold the control panel on the door. 4 on top and usually 2 or 4 holding the corners of the panel in place. Just be careful of the indicator light package that is attached to the front panel. Gently unclip it and you will have free access to all the components behind the panel. Then you will see the lever that pushes the buttons out.

This machine is the last of the Hobart inspired machines but has the power clean pump in it and also the temp hold for the main wash cycles so you have the proper temperature water for the wash cycle. I had a the imperial version of that machine and it worked great with today's detergents and the longer wash time due to reaching the set temp gave the enzymes time to do their work.


Post# 1099043 , Reply# 8   12/2/2020 at 12:02 (1,233 days old) by Ellibee (Los angeles )        
Y'all are awesome

Thank you so much! I will give that a try today and report back.

Post# 1099106 , Reply# 9   12/2/2020 at 20:29 (1,233 days old) by Ellibee (Los angeles )        
It's the latch

Hi all,

It is definitely the latch! The buttons behave properly when I manually trigger the little reset button. Issue is, I couldn't find the exactly correct service manual (though the one I did find helped me identify the part), and I cannot figure out how to fix it. I'm attaching some pictures with notes in the hope that someone will either know or be able to give me some resource where I can learn.

Thank you all so much.


  Photos...       <              >      Photo 1 of 5         View Full Size
Post# 1099109 , Reply# 10   12/2/2020 at 20:56 (1,233 days old) by wiskybill (Canton, Ohio)        
Ebay...

is your friend



CLICK HERE TO GO TO wiskybill's LINK on eBay


  View Full Size
Post# 1099113 , Reply# 11   12/2/2020 at 21:28 (1,233 days old) by Ellibee (Los angeles )        
Fixed! (Sorta)

This definitely isn't kosher but I at least got it running again with duct tape and a piece of scrap plastic... thanks for the ebay link, I'll buy the actual part now.

And thank you so much to everyone! Never thought I'd actually be able to fix it. This dishwasher is amazing, I'm looking forward to keeping it.

Best,

Beth


  Photos...       <              >      Photo 1 of 2         View Full Size
Post# 1099114 , Reply# 12   12/2/2020 at 21:59 (1,233 days old) by RP2813 (Sannazay)        

rp2813's profile picture

And another excellent machine gets saved from the krusher!  We all know a repair "tech" would have simply advised that the machine is too old to fix without even trying to diagnose the problem.

 

This is why I love this site so much!  Enjoy your awesome KitchenAid!


Post# 1099175 , Reply# 13   12/3/2020 at 16:12 (1,232 days old) by Hippiedoll ( arizona )        
YYYYAAAAAAYYYYY!!

hippiedoll's profile picture
WOOOOOO HOOOOOO!
I'm so glad that the advice of others here in the group could help you figure out the problem, mend it (temporarily), and link you with the new part needed!

The friends here are amazing and a true blessing!

CONGRATULATIONS!
Doing the HAPPY DANCE for you on this side of the computer...
😃🥳


Post# 1101882 , Reply# 14   12/24/2020 at 21:08 (1,211 days old) by electronicontrl (Grand Rapids, MI)        
Congratulations!

electronicontrl's profile picture
Your dishwasher is a gem! So glad you get to keep such a beautiful machine.

Post# 1102224 , Reply# 15   12/27/2020 at 16:59 (1,208 days old) by wenric (Yuma)        

Its good to read all of the advice. I just purchased a KUDS23OBO and haven't tested it yet to see that it works. Its good to know what to check. I see that it has one of the cycle buttons depressed but won't know until I get it hooked up to see if it has the same problem. It also has the black control panel and I've been looking for one that is like this one.

  Photos...       <              >      Photo 1 of 2         View Full Size
Post# 1102314 , Reply# 16   12/28/2020 at 15:35 (1,207 days old) by barcoboy (Canada)        

barcoboy's profile picture
Completely normal for the KUDS23 buttons to stay pressed when the door is opened. The "Cancel" button will un-select any of the main cycle options when pressed, and the "Reset Options" button will un-select both the "Sani Rinse" and "Energy Saver Dry" options when pressed. But all these buttons will stay latched when pressed... only the "6 HR Delay Wash" button which is push on/push off, and the "Start" button which is momentary push, don't latch.

BTW, told you it was a KUDS23! :-p

Seriously, these are great dishwashers. I have one as well as a KDS-58 (a portable model of the KDS-18), and I prefer this one. The KDS-58 cleans really well, but I found it left specs of food on the upper rack dishes (even with the constant spray head intact), where the KUDS23 does not. You also don't have to clean any filters on the KUDS23, which is nice.


Post# 1102325 , Reply# 17   12/28/2020 at 17:38 (1,207 days old) by wenric (Yuma)        

You were right! I don't know where the other numbers came from. Thank you for clearing up the situation with the buttons. The people claimed it was only used once a year and the interior looks like it also. I can't imagine having an appliance and only using it once a year!

Post# 1105220 , Reply# 18   1/20/2021 at 10:50 (1,184 days old) by wenric (Yuma)        

This post has been removed by the member who posted it.




Forum Index:       Other Forums:                      



Comes to the Rescue!

The Discuss-o-Mat has stopped, buzzer is sounding!!!
If you would like to reply to this thread please log-in...

Discuss-O-MAT Log-In



New Members
Click Here To Sign Up.



                     


automaticwasher.org home
Discuss-o-Mat Forums
Vintage Brochures, Service and Owners Manuals
Fun Vintage Washer Ephemera
See It Wash!
Video Downloads
Audio Downloads
Picture of the Day
Patent of the Day
Photos of our Collections
The Old Aberdeen Farm
Vintage Service Manuals
Vintage washer/dryer/dishwasher to sell?
Technical/service questions?
Looking for Parts?
Website related questions?
Digital Millennium Copyright Act Policy
Our Privacy Policy